Power Slipping

Soft_Click

Member
I am definitely not certain. I rebuilt it myself and adjusted it according to info from these forums and You Tube. I can't fit an electric choke on this carb since it's so old, so I was going to replace it anyways. If it could fix my power slipping problem, that would be awesome.
 

Zaedster

Future Owner of IH Parts America
I am definitely not certain. I rebuilt it myself and adjusted it according to info from these forums and You Tube. I can't fit an electric choke on this carb since it's so old, so I was going to replace it anyways. If it could fix my power slipping problem, that would be awesome.
Unless that clutch disk was oil fouled I don't see how it would slip at all. If you have a DVOM or tachometer, I would see where the RPMs are at.

Does the carb. operate correctly at idle and rev up fine? Possibly post a video.
 

Soft_Click

Member

I'm installing a tachometer tomorrow. The carb seems to operate okay. Idle seems good and it seems to rev okay. I don't have a lot of experience with carbureted engines though, hard to tell what's normal! I bought a new carb from you guys today, hopefully that helps things
 

Zaedster

Future Owner of IH Parts America

I'm installing a tachometer tomorrow. The carb seems to operate okay. Idle seems good and it seems to rev okay. I don't have a lot of experience with carbureted engines though, hard to tell what's normal! I bought a new carb from you guys today, hopefully that helps things
That carb. sounds like it's working enough to at least get you going. Hard to really tell from a video but if you're pulling 18 inches at idle you're in the ballpark. Hook up a tach and report the RPM's with speeds.

I'm not sure what rear end your truck has in it currently, but it doesn't hurt to check out that also. We've had scouts here that have had completely stripped spider gears that would barely move maybe 15mph max speed. Just a thought. At least jack it up and spin a tire....

I still think the clutch is perfectly fine, you even have a 12" from the looks of it. Unless you REALLY screwed up something I wouldn't worry too much about it.
 

Soft_Click

Member
I have taken off the rear diff cover already. I think it’s a Dana 90 or 60?
The gears looked okay. I had to rebuild the brakes, so I pulled out the axle shafts and everything in there. I can spin the rear wheels by hand when jacked up, takes some force but they spin okay.

I’m really feeling optimistic about the new carb, but I’ll wire up the tach and take it out again hopefully tomorrow. We have snow forecasted soon so I gotta hurry haha
 
Top