IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > Tech Forums > Carb Tech
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

Reply
 
Thread Tools Display Modes
Old 12-04-2019, 06:42 PM   #1
suprhonda
Junior Member
 
Join Date: Dec 2019
Member Number: 9924
Posts: 2
Default 1904 Carb with flooding issues

Hey!

I am working on a 1904 on a Judson Supercharged car. I can get the car to Idle, and start, but as soon as the throttle opens, it floods out. It looks like there is fuel coming from the main metering nozzle in that space cut out for the choke. It also seems to be coming from the accelerator pump even after I have stopped moving the throttle, and I am moving the throttle very slowly just to open a little bit.

I see some 1904 Carbs for sale at IH America, but, the choke set up looks different than the one I have.
https://www.ihpartsamerica.com/store/DPC-CHV.html



I don't know if this will fit? Are they all the same bases and air horn size?

Also, I did read that this was repairable before by a fix to the poppet on the Economizer. I don't think this is done any more? I do have capability of doing fine machining if needed, if there was some direction in how this was done before, I could possibly re create this repair. But again, I would like to know if my symptoms are actually a poppet problem. I was able to test the power valve with Vacuum pump and see that it does lift with just under 5 inches, and holds as well.

Thanks ahead of time for your help!
suprhonda is offline   Reply With Quote
Old 12-07-2019, 04:22 PM   #2
Robert Kenney
Super Moderator
 
Robert Kenney's Avatar
 
Join Date: Aug 2008
Member Number: 543
Location: So Cal
Posts: 3,423
Default Re: 1904 Carb with flooding issues

@ idle if you are getting fuel out of the main nozzle or the accelerator pump discharge, you most likely have an leaking float valve. Easy for debris to get in the way of it sealing off and the fuel bowl will over flow.

If you have an economizer it open all of the time, the worst you'll have it just a tad of richness at low throttle settings. The econo jet is parallel to the main jet.

Also make sure the main metering block is flat. Common for they to be overtightened thus warping the block. This can cause internal passages to mix. There could be a whole myriad of symptoms.

There are a couple of possible 1904 bore sizes along with a respectively larger bolt pattern.

I would just rebuild the 1904 you have. Jeff should be able to get you a kit.

We don't do the econo refit any more. Sorry.
__________________
Robert Kenney

“Don't lift until the fear of death over comes the fear of speed.” Author Unknown
Robert Kenney is offline   Reply With Quote
Old 12-13-2019, 07:17 AM   #3
suprhonda
Junior Member
 
Join Date: Dec 2019
Member Number: 9924
Posts: 2
Default Re: 1904 Carb with flooding issues

Hey Robert.

Thank you for your help. Turns out I was looking park intermittently on random cyl due to a poor grounding issue. I believe this caused the car to run rich as it miss fired just off idea. Very strange problem.

Is there any way I could find out the details of the economic issue and help people out by doing the repair myself for people? I can find some pictures of the repair on Google images, but the actual old threads are gone from the forums. At least my computer won't load them.
suprhonda is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:41 AM.