IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > Sewing Circle > Reader's Ride's
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-20-2013, 03:40 PM   #11
Robert Kenney
Super Moderator
 
Robert Kenney's Avatar
 
Join Date: Aug 2008
Member Number: 543
Location: So Cal
Posts: 3,421
Default Re: 1964 Travelall and 1967 Travelette All Wheel Drive's

Changed the oil and filter, yanked the dizzy and primed it for about 5 minutes... Not I didn't rotate it or verify oil to the top end... restab and advance it a couple of degrees by eye..

Squirted for fuel in the carb and cranked it up it fired immediatly. Ran it at 1500 for about 2 minutes to get oil around good. Had a very slight tick but a few minutes later it sounded like the video attached. Yes really that quiet... Not a sound..

I ran it for about 15 minutes. Drove it back and forth to see that the clutch was ok.. Its a gem... Ac compressor even engaged and the fan blew strong...

1968 travelette first run since parked years ago, - youtube
__________________
Robert Kenney

“Don't lift until the fear of death over comes the fear of speed.” Author Unknown

Last edited by Robert Kenney; 07-21-2013 at 06:08 AM..
Robert Kenney is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:41 AM.