IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > Tech Forums > Fuel Injection
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

Reply
 
Thread Tools Display Modes
Old 02-11-2020, 10:02 PM   #1
Catfishg
Junior Member
 
Join Date: May 2009
Member Number: 1083
Location: Everett, WA
Posts: 10
Default Kwikwire with Hamilton FI

I could not find any info on this subject that answered my novice brain stump, so here it goes:

I have a 1973 Scout II with a 345 in it. Bought the Hamilton FI system a couple of years ago and it definitely improved the reliability, starting and performance of my Scout. So much so that my son blew out the engine!

So...I found a donor 345, did a refresh on it since it seemed to be in great shape and had over 140 psi compression in all cylinders. I also purchased and installed the Kwikwire 14. (Since I would be making such a major investment in it.) The rewire went ok (I think), but it will not fire up.

I purchased a fuel injection test kit for the fuel lines and will be following Bill’s troubleshooting guide that he gives with the bible of instructions, but if anyone has any history with a similar type of electrical rewire after the FI had been working fine, I would love to hear any pointers. Thanks!
Catfishg is offline   Reply With Quote
Reply

Tags
efi, fuel injection, hamilton, rewire, wiring

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:53 PM.