IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > Sewing Circle > Reader's Ride's
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

Reply
 
Thread Tools Display Modes
Old 03-29-2013, 09:06 AM   #31
71mtnscout
Senior Member
 
71mtnscout's Avatar
 
Join Date: Oct 2009
Member Number: 1369
Location: Menifee, CA
Posts: 522
Default Re: Started my "trail Rig" build.....Finally!!

Quote:
Originally Posted by fdchappie View Post
did this rig have a "sway bar" between the front shackles?
It has the plate bolted between the shackles, I was looking at it closer last night and it looks to be a factory part.
__________________
63 S80...."Beater"....
78 Honda CB750K
11 Ranger S/C 2wd
71mtnscout is offline   Reply With Quote
Old 04-02-2013, 06:07 PM   #32
71mtnscout
Senior Member
 
71mtnscout's Avatar
 
Join Date: Oct 2009
Member Number: 1369
Location: Menifee, CA
Posts: 522
Default Re: Started my "trail Rig" build.....Finally!!

Work some more today.......dropped the trans and t-case out and started cleaning up the frame for paint. Then I noticed that the engine mount on the drivers side had a cracked and pulled weld on the top of it. So I got the grinder out and noticed that it had the most horrible welds that I've ever seen on it, no big, I went to work grinding the welds off so I could re-weld it.........grind, hammer, grind, hammer, till it starts moving. I also noticed that that funky track bar mount was moving too. Little coaxing and some more grinding and everything is really moving now, it finally falls off............

Son of a beyach........the bottom of the frame where the track bar mount was is rusted through and theres a pretty good size piece of frame gone. To top it off there are all kinds of cracks and tears in the frame in that whole general area. Guess I will be doing some repair work on the frame now........
__________________
63 S80...."Beater"....
78 Honda CB750K
11 Ranger S/C 2wd
71mtnscout is offline   Reply With Quote
Old 04-04-2013, 09:33 PM   #33
71mtnscout
Senior Member
 
71mtnscout's Avatar
 
Join Date: Oct 2009
Member Number: 1369
Location: Menifee, CA
Posts: 522
Default Re: Started my "trail Rig" build.....Finally!!

Today I started the frame repair. Got the grinder out and cleaned up the garbage welds that were there, "v'd" the cracks out and drilled the ends. Then burned the v's up and got the grinder out again to dress the frame. Thats all I can do today, I need to get some steel for patching the rotted out holes in the side and bottom. Will pick up some flat stock tomorrow for the repair.
__________________
63 S80...."Beater"....
78 Honda CB750K
11 Ranger S/C 2wd
71mtnscout is offline   Reply With Quote
Old 04-06-2013, 06:50 PM   #34
71mtnscout
Senior Member
 
71mtnscout's Avatar
 
Join Date: Oct 2009
Member Number: 1369
Location: Menifee, CA
Posts: 522
Default Re: Started my "trail Rig" build.....Finally!!

I decided to fix the 71's frame since I have a lot of time and work invested already. First pic is the prep of the frame for the big repair. You can see the chunk missing from the side and if you look close you can see the hole in the bottom. The black circle had a big tear in the frame that I already repaired, and there was some cracks to the left of the rear steering box mount that I also welded up.



The repair is done at this point. You can see the patch that I welded in where the hole was on the side along with the patch plate that added to the bottom where the hole was. My welding skills are improving as long as I weld from the top, need to practice more on overhead, and side welding.


__________________
63 S80...."Beater"....
78 Honda CB750K
11 Ranger S/C 2wd
71mtnscout is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:42 PM.