IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > Tech Forums > Transmission Tech
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

Reply
 
Thread Tools Display Modes
Old 01-03-2019, 04:42 PM   #1
Richard
Senior Member
 
Join Date: Mar 2009
Member Number: 969
Location: So Cal
Posts: 215
Default Speedo Cable issue

Just installed a T19 and D20 into my 1977 SII - 4cyl 1bbl. It works just fine, seems a bit better throttle response than the anemic 3 spd that was in before.

New issue: the speedometer is not working. when the speedo cable is hooked up to transfer case, no go on speedo. I tested the speedo with a drill gun - speedo works just fine. when connected to tranny,nothing. Attached picture shows the outlet at transfer case fr speedo cable. I am wondering: is it possible that the round part inside is broken? is it plastic? does this require a removal of the back end of the transfer case to remedy?

Also, the large grey object? I am guessing it is a "reducer" of some sort?

let me know and thanks?
Attached Images
File Type: jpg speedo gear .jpg (34.3 KB, 22 views)
File Type: jpg speedo gear 2.JPG (148.4 KB, 24 views)
Richard is offline   Reply With Quote
Old 01-08-2019, 05:02 PM   #2
Richard
Senior Member
 
Join Date: Mar 2009
Member Number: 969
Location: So Cal
Posts: 215
Default Re: Speedo Cable issue

this may be a dumb question but, I have to ask:

is it possible that the speedo cable is not turning the correct way. When i have a drill gun running the speedo cable in reverse (counter-clock wise), the speedometer shows that it's working. The speedo gear that is plugged into the D20 transfer case is turning clockwise. or am I missing something here? DAMN!

Did the 3 speed have a"reverse (CCW)" gear, and the 4 speed have a forward (CW) gear turn?
Richard is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:02 PM.