IH PARTS AMERICA
Click Here!

Go Back   IH PARTS AMERICA > IH Parts America Sponsored Events > IH Sierra Fall Rallye
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Photo Gallery IH Store Home

Reply
 
Thread Tools Display Modes
Old 10-11-2015, 10:16 PM   #1
darren y
Senior Member
 
Join Date: Feb 2009
Member Number: 845
Location: Sparks, NV
Age: 48
Posts: 179
Default 9th annual IHSFR

Good times this year @ the IHSFR

although my day didn't end so well, after the awards I headed down towards placerville to pick up a c-series windshield for $100, I was on hwy 50 headed east just before cameron park, my Travelall was running a little hot, thought I'd stop get gas & check things out next exit, a few seconds later my upper radiator hose blew! I was about a mile short cameron park, thinking I wish I had more you guys #'s in my phone, I called aaa, g & o towing picked me up & dropped me off @ auto parts store just a little over a mile away, I thanked them, already had the busted hose in hand I headed into the parts store, 1st thing they asked if I owned the green Jeep? I knew this was going to go bad, but they let me go in back pick my own hoses (since they couldn't find my Travelall or even 1100 in the computer, asked if a 241 was a dodge motor) any way I bought 2 hoses cut & spliced, filled the radiator, sprayed the cap with wd40, it was a little hard to start but seemed ok once I got it running, drove around the parking lot of the strip mall, everything seemed ok, filled up with gas, still hard to start but everything evened out once I got it going, s I got back on 50 headed east, I didn't May it far at all & things got loud!, lost power, it felt like I was running on 4 or 5 cylinders, & started smoking bad, thankfully the next exit ponderosa, was less than 3 miles & I was over 2/3 way the way there already, pulled in to chevron backed up to the curb, shut it down got out popped the hood, valve cover is pushed out on the driver side (look close in the pics) 3rd & possibly 4th cylinders, called aaa back, & 20 mins later I'm loading my Travelall on the g & o wrecker for the second time today, only this time they took me home to sparks nv
haven't pulled the valve cover yet as it was 7:30 & getting dark by the time I made it home.
Possibly busted a rocker or a push rod??
So it was great seeing everyone & taking a weekend off, & winning the 1st place Travelall trophy! But my allergies kicked my ass all weekend I guess I'm not used to all that green stuff, I live in the desert!
As for the Travelall I'll tear it apart, if its bad I'll probably swap in a v8, just another project to add to the list...

Let's see some pics from this weekend!!
Attached Images
File Type: jpg IMG_2393.jpg (57.3 KB, 133 views)
File Type: jpg IMG_2394.jpg (69.0 KB, 128 views)
File Type: jpg IMG_2396.jpg (73.4 KB, 115 views)
File Type: jpg IMG_2397.jpg (79.3 KB, 118 views)
File Type: jpg IMG_2404.jpg (90.8 KB, 113 views)
File Type: jpg IMG_2407.jpg (63.7 KB, 120 views)
__________________
To many Binders, hit me up for parts....

4-sale?:
Early 60's Metro (profile pic)
Many 60's trucks/t-alls
71 1600 frame
71 1110
73 1500 frame
Scout II crawler
Scout II frame/tub (lifted/reverse shackle)
77 IH School Bus
+ several sheds full of IH Parts….

Not 4-sale:
(2) Scout II's,
(2) 60's truck/t-alls,
56 S-160 Dump truck ('Mater project)
71 1600 Loadstar crewcab
(always looking for 60's Truck/ T-all parts)


775-720-3998
darreny@charter.net
Instagram: ihaddict
darren y is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:51 AM.